Security Advisory 2014-02 – SQL injection issue

  • January 2014

January 28, 2014 — Please read carefully and check if the version of your OTRS system is affected by this vulnerability.

Report a Vulnerability

security@otrs.org

PGP Key

  • pub 2048R/9C227C6B 2011-03-21 [expires at: 2014-03-20]
  • uid OTRS Security Team <security@otrs.org>
  • Fingerprint E330 4608 DA6E 34B7 1551 C244 7F9E 44E9 9C22 7C6B

Security Advisory Details

  • ID: OSA-2014-02
  • Date: 2014-01-28
  • Title: SQL injection issue
  • Severity: Low (Overall CVSS Score : 3.6)
  • Affected:
    – OTRS 3.3.x
    – OTRS 3.2.x
    – OTRS 3.1.x
  • Fixed in:
    – OTRS 3.3.4, 3.2.14, 3.1.19
  • FULL CVSS v2 VECTOR: (AV:A/AC:L/AU:S/C:N/I:P/A:P/E:ND/RL:OF/RC:C/CDP:N/TD:ND/CR:ND/IR:ND/AR:ND)
  • References: CVE-2014-1471

Vulnerability Description

This Advisory covers vulnerabilities discovered in the OTRS core system.

  • An attacker with a valid customer or agent login could inject SQL in the ticket search URL.

Affected by this vulnerability are all releases of OTRS 3.1.x up to and including 3.1.18, 3.2.x up to and including 3.2.13 and 3.3.x up to and including 3.3.3.

Recommended Resolution

This vulnerability is fixed in the latest versions of OTRS and the affected packages, and it is recommended to upgrade to one of these.

Here are detailed informations about the required changes:

OTRS

However, to avoid unwanted side effects, we recommend a complete update.

Thanks to Karsten Nielsen (Vasgard GmbH) for discovering and reporting this issue.