Security Advisory 2014-03 – XSS Issue

  • February 2014

February 25, 2014 — Please read carefully and check if the version of your OTRS system is affected by this vulnerability.

Report a Vulnerability

security@otrs.org

PGP Key

  • pub 2048R/9C227C6B 2011-03-21 [expires at: 2014-03-20]
  • uid OTRS Security Team <security@otrs.org>
  • Fingerprint E330 4608 DA6E 34B7 1551 C244 7F9E 44E9 9C22 7C6B

Security Advisory Details

  • ID: OSA-2014-03
  • Date: 2014-02-25
  • Title: XSS issue
  • Severity: Low (Overall CVSS Score : 3.4)
  • Product: OTRS 3.1.x, 3.2.x, 3.3.x
  • Fixed in: OTRS 3.1.20, 3.2.15, 3.3.5
  • URL: https://www.otrs.com/security-advisory-2014-03-xss-issue/
  • FULL CVSS v2 VECTOR: (AV:N/AC:M/AU:N/C:N/I:P/A:N/E:POC/RL:OF/RC:C/CDP:ND/TD:ND/CR:ND/IR:ND/AR:ND)
  • References: CVE-2014-1695

Vulnerability Description

This Advisory covers vulnerabilities discovered in the OTRS core system.

  • An attacker could send a specially prepared HTML email to OTRS. If he can then trick an agent into following a special link to display this email, JavaScript code would be executed.

Affected by this vulnerability are all releases of OTRS 3.1.x up to and including 3.1.19, 3.2.x up to and including 3.2.14 and 3.3.x up to and including 3.3.4.

Recommended Resolution

This vulnerability is fixed in the latest versions of OTRS and the affected packages, and it is recommended to upgrade to one of these.

Fixed releases can be found at:

Here are detailed informations about the required changes:

OTRS

However, to avoid unwanted side effects, we recommend a complete update.

Thanks to Adam Ziaja (http://adamziaja.com) for discovering and reporting this issue.