Security Advisory 2016-01: Security Update for OTRS FAQ package

 

July 01, 2016 — Please read carefully and check if the version of your OTRS system is affected by this vulnerability.

Please send information regarding vulnerabilities in OTRS to: security@otrs.org

PGP Key

  • pub 2048R/9C227C6B 2011-03-21 [expires at: 2017-08-20]
  • uid OTRS Security Team <security@otrs.org>
  • GPG Fingerprint E330 4608 DA6E 34B7 1551 C244 7F9E 44E9 9C22 7C6B

Security Advisory Details

 

  • ID: OSA-2016-01
  • Date: 2016-06-25
  • Title: FAQ Database Access
  • Severity: 6.5
  • Product: FAQ 5.0.x (OTRS 5), FAQ 4.0.x (OTRS 4), FAQ 2.3.x (OTRS 3.3), FAQ 2.2.x, FAQ 2.1.x, FAQ 2.0.x
  • Fixed in: FAQ 5.0.5 (OTRS 5), FAQ 4.0.5 (OTRS 4), FAQ 2.3.6 (OTRS 3.3)
  • FULL CVSS v2 VECTOR: (AV:N/AC:M/AU:N/C:C/I:P/A:P/E:POC/RL:OF
    /RC:C/CDP:ND/TD:ND/CR:ND/IR:ND/AR:ND)
  • References: CVE-2016-5843

 

Vulnerability Description

 

This advisory covers vulnerabilities discovered in the OTRS FAQ module.

 

Information Disclosure

 

  • An attacker could access and manipulate the database with an HTTP request.

 

Affected by this vulnerability are all releases of FAQ:

  • FAQ 2.0.x up to and including 2.0.8
  • FAQ 2.1.x up to and including 2.1.4
  • FAQ 2.2.x up to and including 2.2.3
  • FAQ 2.3.x up to and including 2.3.4
  • FAQ 4.0.x up to and including 4.0.3
  • FAQ 5.0.x up to and including 5.0.3

This vulnerability is fixed in FAQ 5.0.5, FAQ 4.0.5, and FAQ 2.3.6 and it is recommended to upgrade to one of these versions.

Fixed FAQ releases can be found at:

Here are detailed information about the required changes:

However, to avoid unwanted side effects, we recommend a complete update.

Thanks to Michael Sincavage for discovering and reporting this issue.