Security Advisory 2016-02: Security Update for OTRS

 

November 01, 2016 — Please read carefully and check if the version of your OTRS system is affected by this vulnerability.

Please send information regarding vulnerabilities in OTRS to: security@otrs.org

PGP Key

  • pub 2048R/9C227C6B 2011-03-21 [expires at: 2017-08-20]
  • uid OTRS Security Team <security@otrs.org>
  • GPG Fingerprint E330 4608 DA6E 34B7 1551 C244 7F9E 44E9 9C22 7C6B

Security Advisory Details

 

  • ID: OSA-2016-02
  • Date: 2016-11-01
  • Title: Stored CSS Vulnerability
  • Severity: low
  • Product: OTRS 3.3.x 4.0.x 5.0.x
  • Fixed in: OTRS 3.3.16 4.0.19 5.0.14
  • FULL CVSS v3 VECTOR:CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
  • References: CVE-2016-9139

 

Vulnerability Description

 

This advisory covers vulnerabilities discovered in the OTRS framework.

 

Information Disclosure

 

  • An attacker could trick an authenticated agent or customer into opening a malicious attachment which could lead to the execution of JavaScript in OTRS context.

 

Affected by this vulnerability are all releases of OTRS:

  • OTRS 3.3.x up to and including 3.3.15
  • OTRS 4.0.x up to and including 4.0.18
  • OTRS 5.0.x up to and including 5.0.13

This vulnerability is fixed in the latest versions of OTRS, and it is recommended to upgrade to one of these.

Fixed FAQ releases can be found at:

Here are detailed information about the required changes:

However, to avoid unwanted side effects, we recommend a complete update.

Thanks to Jakub Żoczek (Allegro) for discovering and reporting this issue.