Security Advisory 2017-03: Security Update for all OTRS Versions

 

June 06, 2017 — Please read carefully and check if the version of your OTRS system is affected by this vulnerability.

Please send information regarding vulnerabilities in OTRS to: security@otrs.org

PGP Key

  • pub 2048R/9C227C6B 2011-03-21 [expires at: 2017-08-20]
  • uid OTRS Security Team <security@otrs.org>
  • GPG Fingerprint E330 4608 DA6E 34B7 1551 C244 7F9E 44E9 9C22 7C6B

Security Advisory Details

 

  • ID: OSA-2017-03
  • Date: 2017-06-06
  • Title: Incorrect Access Control in OTRS
  • Severity: High
  • Product: OTRS 5.0.x, OTRS 4.0.x, OTRS 3.3.x
  • Fixed in: OTRS 5.0.20, OTRS 4.0.24, OTRS 3.3.17
  • FULL CVSS v3 VECTOR:
  • References: CVE-2017-9324

 

Vulnerability Description

 

This advisory covers vulnerabilities discovered in the OTRS framework.

 

Privilege Escalation

 

An attacker with agent permission is capable by opening a specific URL in a browser to gain administrative privileges / full access. Afterward, all system settings can be read and changed.

 

Affected by this vulnerability are all releases of OTRS 5.0.x up to and including 5.0.19, OTRS 4.0.x up to and including 4.0.23 and OTRS 3.3.x up to and including 3.3.16.

This vulnerability is fixed in the latest versions of OTRS, and it is recommended to upgrade to the latest patch level.

Fixed releases can be found at:

https://www.otrs.com/category/release-and-security-notes-en/

Thanks to Sebastian Auwärter and Joerg-Thomas Vogt for discovering and
reporting this issue.