Security Advisory 2017-04: Security Update for all OTRS Versions

 

September 19, 2017 — Please read carefully and check if the version of your OTRS system is affected by this vulnerability.

Please send information regarding vulnerabilities in OTRS to: security@otrs.org

PGP Key

  • pub 2048R/9C227C6B 2011-03-21 [expires at: 2017-08-20]
  • uid OTRS Security Team <security@otrs.org>
  • GPG Fingerprint E330 4608 DA6E 34B7 1551 C244 7F9E 44E9 9C22 7C6B

Security Advisory Details

 

  • ID: OSA-2017-04
  • Date: 2017-09-19
  • Title: Code Injection / Privilege Escalation OTRS
  • Severity: High
  • Product: OTRS 6.0.x, OTRS 5.0.x, OTRS 4.0.x, OTRS 3.3.x
  • Fixed in: OTRS 6.0.beta2, OTRS 5.0.23, OTRS 4.0.25, OTRS 3.3.18
  • FULL CVSS v3 VECTOR: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H/E:P/RL:O/RC:R
  • References: CVE-2017-14635

 

Vulnerability Description

 

This advisory covers vulnerabilities discovered in the OTRS framework.

 

Privilege Escalation

 

An attacker who is logged into OTRS as an agent with write permissions for statistics can inject arbitrary code into the system. This can lead to serious problems like privilege escalation, data loss, and denial of service.

 

Affected by this vulnerability are OTRS 6.0.beta1, all releases of OTRS 5.0.x up to and including 5.0.22, OTRS 4.0.x up to and including 4.0.24 and OTRS 3.3.x up to and including 3.3.17.

This vulnerability is fixed in the latest versions of OTRS, and it is recommended to upgrade to the latest patch level.

Fixed releases can be found at:

https://www.otrs.com/category/release-and-security-notes-en/

Detailed information about the changes:

OTRS 6:

OTRS 5

OTRS 4

OTRS 3.3

However, to avoid unwanted side effects, we recommend a complete update.

Thanks to Francesco Sirocco for discovering and reporting this issue.